# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$([0-9]+)(\.[0-9]{1,2})?/$\1\2/g;t' <<< "$128.99
$140
$6.82
$4.5"