package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$([0-9]+)(\.[0-9]{1,2})?`)
var str = `$128.99
$140
$6.82
$4.5`
var substitution = "$\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}