use strict;
my $str = '$128.99
$140
$6.82
$4.5';
my $regex = qr/\$([0-9]+)(\.[0-9]{1,2})?/p;
my $subst = '$\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";