const regex = /\$([0-9]+)(\.[0-9]{1,2})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$([0-9]+)(\\.[0-9]{1,2})?', 'g')
const str = `\$128.99
\$140
\$6.82
\$4.5`;
const subst = `$\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);