// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$([0-9]+)(\.[0-9]{1,2})?").unwrap();
let string = "$128.99
$140
$6.82
$4.5";
let substitution = "$\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}