#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$([0-9]+)(\.[0-9]{1,2})?"
Local $sString = "$128.99" & @CRLF & _
"$140" & @CRLF & _
"$6.82" & @CRLF & _
"$4.5"
Local $sSubst = "$\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)