re = /\$([0-9]+)(\.[0-9]{1,2})?/
str = '$128.99
$140
$6.82
$4.5'
subst = '$\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result