#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(and|or)(?=(?:[^']*'[^']*')*[^']*$)"
Local $sString = "Text 1: firstName eq 'John' and tenantId eq '32323232'" & @CRLF & _
"Text 2: firstName like 'J%' or companyName eq 'IBM'" & @CRLF & _
"Text 3: companyName like 'John and Sons'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")