import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(and|or)(?=(?:[^']*'[^']*')*[^']*$)";
final String string = "Text 1: firstName eq 'John' and tenantId eq '32323232'\n"
+ "Text 2: firstName like 'J%' or companyName eq 'IBM'\n"
+ "Text 3: companyName like 'John and Sons'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}