use strict;
my $str = 'Text 1: firstName eq \'John\' and tenantId eq \'32323232\'
Text 2: firstName like \'J%\' or companyName eq \'IBM\'
Text 3: companyName like \'John and Sons\'';
my $regex = qr/(and|or)(?=(?:[^']*'[^']*')*[^']*$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}