const regex = /(and|or)(?=(?:[^']*'[^']*')*[^']*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(and|or)(?=(?:[^\']*\'[^\']*\')*[^\']*$)', 'g')
const str = `Text 1: firstName eq 'John' and tenantId eq '32323232'
Text 2: firstName like 'J%' or companyName eq 'IBM'
Text 3: companyName like 'John and Sons'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}