$re = '/(and|or)(?=(?:[^\']*\'[^\']*\')*[^\']*$)/';
$str = 'Text 1: firstName eq \'John\' and tenantId eq \'32323232\'
Text 2: firstName like \'J%\' or companyName eq \'IBM\'
Text 3: companyName like \'John and Sons\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);