using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(and|or)(?=(?:[^']*'[^']*')*[^']*$)";
string input = @"Text 1: firstName eq 'John' and tenantId eq '32323232'
Text 2: firstName like 'J%' or companyName eq 'IBM'
Text 3: companyName like 'John and Sons'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}