import Foundation
let pattern = #"(and|or)(?=(?:[^']*'[^']*')*[^']*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Text 1: firstName eq 'John' and tenantId eq '32323232'
Text 2: firstName like 'J%' or companyName eq 'IBM'
Text 3: companyName like 'John and Sons'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)