re = /(and|or)(?=(?:[^']*'[^']*')*[^']*$)/
str = 'Text 1: firstName eq \'John\' and tenantId eq \'32323232\'
Text 2: firstName like \'J%\' or companyName eq \'IBM\'
Text 3: companyName like \'John and Sons\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end