#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{4}\s*年\s*\d{1,2}\s*月\s*\d{1,2}\s*日)"
Local $sString = "1959年12月16日 (昭和34年)" & @CRLF & _
"1959 年12月16日 (昭和34年)" & @CRLF & _
"1959 年 12 月 16 日 (昭和34年)" & @CRLF & _
"1959 年 12 月 16 日 (昭和34年)" & @CRLF & _
"1959 年12 月 16日 (昭和34年)" & @CRLF & _
"1959 年 12 月 16 日(昭和34年)" & @CRLF & _
"1959 年 1 月 1 日(昭和34年)" & @CRLF & _
"1959 年 12 月 1 日(昭和34年)" & @CRLF & _
"1959 年 1 月 16 日(昭和34年)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")