re = /(\d{4}\s*年\s*\d{1,2}\s*月\s*\d{1,2}\s*日)/m
str = '1959年12月16日 (昭和34年)
1959 年12月16日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年12 月 16日 (昭和34年)
1959 年 12 月 16 日(昭和34年)
1959 年 1 月 1 日(昭和34年)
1959 年 12 月 1 日(昭和34年)
1959 年 1 月 16 日(昭和34年)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end