using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}\s*年\s*\d{1,2}\s*月\s*\d{1,2}\s*日)";
string input = @"1959年12月16日 (昭和34年)
1959 年12月16日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年12 月 16日 (昭和34年)
1959 年 12 月 16 日(昭和34年)
1959 年 1 月 1 日(昭和34年)
1959 年 12 月 1 日(昭和34年)
1959 年 1 月 16 日(昭和34年)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}