// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4}\s*年\s*\d{1,2}\s*月\s*\d{1,2}\s*日)").unwrap();
let string = "1959年12月16日 (昭和34年)
1959 年12月16日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年 12 月 16 日 (昭和34年)
1959 年12 月 16日 (昭和34年)
1959 年 12 月 16 日(昭和34年)
1959 年 1 月 1 日(昭和34年)
1959 年 12 月 1 日(昭和34年)
1959 年 1 月 16 日(昭和34年)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}