const regex = /otpauth:\/\/([ht]otp)\/(?:[a-zA-Z0-9%]+:)?([^\?]+)\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('otpauth:\\\/\\\/([ht]otp)\\\/(?:[a-zA-Z0-9%]+:)?([^\\?]+)\\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?', 'g')
const str = `otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1
otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15
otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456
otpauth://totp/fred?secret=2345678BCDC&issuer=Example`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}