use strict;
my $str = 'otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1
otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15
otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456
otpauth://totp/fred?secret=2345678BCDC&issuer=Example';
my $regex = qr/otpauth:\/\/([ht]otp)\/(?:[a-zA-Z0-9%]+:)?([^\?]+)\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}