# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"otpauth:\/\/([ht]otp)\/(?:[a-zA-Z0-9%]+:)?([^\?]+)\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?"
test_str = ("otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1\n\n"
"otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15\n\n"
"otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456\n\n"
"otpauth://totp/fred?secret=2345678BCDC&issuer=Example")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.