$re = '/otpauth:\/\/([ht]otp)\/(?:[a-zA-Z0-9%]+:)?([^\?]+)\?secret=([0-9A-Za-z]+)(?:.*(?:<?counter=)([0-9]+))?/';
$str = 'otpauth://hotp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=1
otpauth://totp/Example:testuser?secret=1234556677ABC&issuer=Example&counter=15
otpauth://hotp/Example:uncle@sam.com?secret=ABC0123456
otpauth://totp/fred?secret=2345678BCDC&issuer=Example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);