import Foundation
let pattern = #"\/fpko\/(rt)\/(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"22-04-2013"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\/fpko\/$2""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}