package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([0-9]*\.?[0-9]*)\s*%`)
var str = `(x-10)+1.23 * 40.014 dd % something else
(x\1-0.3) + (y/1-.15)
(x\(1/30.011%) + (y/(1/15%)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}