re = /([0-9]*\.?[0-9]*)\s*%/mi
str = '(x-10)+1.23 * 40.014 dd % something else
(x\\1-0.3) + (y/1-.15)
(x\\(1/30.011%) + (y/(1/15%)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end