import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]*\\.?[0-9]*)\\s*%";
final String string = "(x-10)+1.23 * 40.014 dd % something else\n"
+ "(x\\1-0.3) + (y/1-.15)\n"
+ "(x\\(1/30.011%) + (y/(1/15%)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}