use strict;
my $str = '(x-10)+1.23 * 40.014 dd % something else
(x\\1-0.3) + (y/1-.15)
(x\\(1/30.011%) + (y/(1/15%)
';
my $regex = qr/([0-9]*\.?[0-9]*)\s*%/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}