import re
regex = re.compile(r"([0-9]*\.?[0-9]*)\s*%", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("(x-10)+1.23 * 40.014 dd % something else\n"
"(x\\1-0.3) + (y/1-.15)\n"
"(x\\(1/30.011%) + (y/(1/15%)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")