using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\xE8-\xEB](?!.*;)";
string substitution = @"e";
string input = @"Joëlle;Dupont;123456;joëlle.dupont@mail.com
Alex;Léger;134234;alex.léger@mail.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}