import Foundation
let pattern = #"[\xE8-\xEB](?!.*;)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Joëlle;Dupont;123456;joëlle.dupont@mail.com
Alex;Léger;134234;alex.léger@mail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"e"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)