$re = '/[\xE8-\xEB](?!.*;)/';
$str = 'Joëlle;Dupont;123456;joëlle.dupont@mail.com
Alex;Léger;134234;alex.léger@mail.com';
$subst = "e";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;