re = /[\xE8-\xEB](?!.*;)/
str = 'Joëlle;Dupont;123456;joëlle.dupont@mail.com
Alex;Léger;134234;alex.léger@mail.com'
subst = 'e'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result