const regex = /[\xE8-\xEB](?!.*;)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\xE8-\\xEB](?!.*;)', 'g')
const str = `Joëlle;Dupont;123456;joëlle.dupont@mail.com
Alex;Léger;134234;alex.léger@mail.com`;
const subst = `e`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);