# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ng-show="([\s\S]*)"//;t' <<< "<span ng-show=\"vm.formName.fieldName.$error.required\">*</span>"