#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "ng-show="([\s\S]*)""
Local $sString = "<span ng-show="vm.formName.fieldName.$error.required">*</span>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)