re = /ng-show="([\s\S]*)"/
str = '<span ng-show="vm.formName.fieldName.$error.required">*</span>'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result