$re = '/ng-show="([\s\S]*)"/';
$str = '<span ng-show="vm.formName.fieldName.$error.required">*</span>';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;