import Foundation
let pattern = #"ng-show="([\s\S]*)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<span ng-show="vm.formName.fieldName.$error.required">*</span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}