using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ng-show=""([\s\S]*)""";
string substitution = @"";
string input = @"<span ng-show=""vm.formName.fieldName.$error.required"">*</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}