# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(Channel\:) (.+?) \(Total memory: ()\)$//gm;t' <<< "Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
"