re = /^(Channel\:) (.+?) \(Total memory: ()\)$/m
str = 'Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result