const regex = new RegExp('^(Channel\\:) (.+?) \\(Total memory: ()\\)$', 'gm')
const str = `Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);