use strict;
my $str = 'Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
';
my $regex = qr/^(Channel\:) (.+?) \(Total memory: ()\)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";