package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Channel\:) (.+?) \(Total memory: ()\)$`)
var str = `Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}