using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Channel\:) (.+?) \(Total memory: ()\)$";
string substitution = @"";
string input = @"Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}