$re = '/^(Channel\:) (.+?) \(Total memory: ()\)$/m';
$str = 'Mo 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;