#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]"
Local $sString = "Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)