using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]";
string substitution = @"";
string input = @"Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}