// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]").unwrap();
let string = "Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}